Here is a script:
/ip firewall mangle
add action=mark-connection chain=prerouting connection-bytes=\
262146-4294967295 in-interface=ether1 new-connection-mark=download \
protocol=tcp src-port=21,80
add action=mark-packet chain=prerouting connection-mark=download \
in-interface=ether1 new-packet-mark=download passthrough=no
/queue type
add kind=pcq name=shape pcq-classifier=src-address pcq-dst-address6-mask=64 \
pcq-rate=128k pcq-src-address6-mask=64
/queue tree
add max-limit=128k name=Download packet-mark=download parent=global queue=\
shape
Not: ether1 = WAN interface
if you have two ISP and configure as load Balancing, you must add two Mangle
Ex.
/ip firewall mangle
add action=mark-connection chain=prerouting connection-bytes=\
262146-4294967295 in-interface=ether1 new-connection-mark=download \
protocol=tcp src-port=21,80
add action=mark-packet chain=prerouting connection-mark=download \
in-interface=ether1 new-packet-mark=download passthrough=no
/ip firewall mangle
add action=mark-connection chain=prerouting connection-bytes=\
262146-4294967295 in-interface=ether2 new-connection-mark=download \
protocol=tcp src-port=21,80
add action=mark-packet chain=prerouting connection-mark=download \
in-interface=ether1 new-packet-mark=download passthrough=no
No comments:
Post a Comment