• Breaking News

    Monday 9 January 2017

    106. Mikrotik Load Balancing(PPC Method) 2 WANs(Static IP)


    You can contact me: plus.google.com/+PhallaCCMT; youtube.com/phallaccmt; facebook.com/Phalla.CCMT; twitter.com/PhallaCCMT and Phalla.CCMT@gmail.com

    Script:

    /ip address
    add address=103.28.2.254/30 interface=WAN1
    add address=103.28.0.254/30 interface=WAN2
    add address=192.168.2.1/24 interface=bridge-LAN

    /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=103.28.3.187,8.8.8.8

    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

    add chain=prerouting dst-address=103.28.2.252/30 action=accept in-interface=bridge-LAN
    add chain=prerouting dst-address=103.28.0.252/30 action=accept in-interface=bridge-LAN

    add chain=prerouting dst-address-type=!local in-interface=bridge-LAN per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=bridge-LAN per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

    add chain=prerouting connection-mark=WAN1_conn in-interface=bridge-LAN action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=bridge-LAN action=mark-routing new-routing-mark=to_WAN2

    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade

    /ip route
    add dst-address=0.0.0.0/0 gateway=103.28.2.253 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=103.28.0.253 routing-mark=to_WAN2 check-gateway=ping

    add dst-address=0.0.0.0/0 gateway=103.28.2.253 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=103.28.0.253 distance=2 check-gateway=ping


    Note: if you have more then 2 WANs you just add:

    1. ip --> Address
    2. ip --> firewall --> Mangle
    3. ip --> firewall --> NAT
    4. ip --> route.

    Example: you have three WANs:

    /ip address
    add address=103.28.2.254/30 interface=WAN1
    add address=103.28.0.254/30 interface=WAN2
    add address=192.168.2.1/24 interface=bridge-LAN

    /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=103.28.3.187,8.8.8.8

    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

    add chain=prerouting dst-address=103.28.2.252/30 action=accept in-interface=bridge-LAN
    add chain=prerouting dst-address=103.28.0.252/30 action=accept in-interface=bridge-LAN

    add chain=prerouting dst-address-type=!local in-interface=bridge-LAN per-connection-classifier=both-addresses-and-ports:3/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=bridge-LAN per-connection-classifier=both-addresses-and-ports:3/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

    add chain=prerouting connection-mark=WAN1_conn in-interface=bridge-LAN action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=bridge-LAN action=mark-routing new-routing-mark=to_WAN2

    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade

    /ip route
    add dst-address=0.0.0.0/0 gateway=103.28.2.253 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=103.28.0.253 routing-mark=to_WAN2 check-gateway=ping

    add dst-address=0.0.0.0/0 gateway=103.28.2.253 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=103.28.0.253 distance=2 check-gateway=ping


    --------------------Add Config--------------------------
    /ip address
    add address=X.X.X.X/X interface=WAN3

    /ip firewall mangle
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
    add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
    add chain=prerouting dst-address=X.X.X.X/X action=accept in-interface=bridge-LAN
    add chain=prerouting dst-address-type=!local in-interface=bridge-LAN per-connection-classifier=both-addresses-and-ports:3/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
    add chain=prerouting connection-mark=WAN3_conn in-interface=bridge-LAN action=mark-routing new-routing-mark=to_WAN3

    /ip firewall nat
    add chain=srcnat out-interface=WAN3 action=masquerade

    /ip route
    add dst-address=0.0.0.0/0 gateway=X.X.X.X/X routing-mark=to_WAN3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=X.X.X.X/X distance=1 check-gateway=ping
    ------------------------------------------------------------

    Note: per-connection-classifier=both-addresses-and-ports:3/2 is equal the amount of your WANs.

    Ref: http://wiki.mikrotik.com/wiki/Load_Balancing

    No comments:

    Post a Comment

    Fashion

    Beauty

    Travel